Testing Emails in non-production environment is sending multiple emails to one user email address



Description of Issue

When printing payroll advices in a Test environment to test if the emails will send to employees, all the individual emails are going to one user's email who works in IT. They are getting separate emails for each employee.



Context
  • System Administration

  • System Settings 

  • Email Override Configuration

  • Payroll



Cause

The Override Enabled checkbox was checked in System Settings with that User's email defined. 



Resolution
  1. Go to System Settings (System Administration>General Administration>System Settings)

  2. Click Email Override Configuration in the toolbar. 

    1. If the Override Enabled checkbox should not be checked, click Update and uncheck the checkbox. Click Accept. 

    2. If the Override Enabled should be checked but emails need to send to another User, click Update and define the correct email address. Click Accept 



Additional Information
  • This is fairly standard practice when testing emails so emails do not send out to employees. 

  • The Override Enable checkbox is described as:

    • Prevents the non-production system from sending email messages.

    • Override email address when it does not match one of the allowed emails below. When unchecked, all emails will be delivered from this environment.  

  • Note: when the Override option is enabled and a test payroll is processed, all employee advice emails will send to that user's email individually. (Example is there are 500 employees setup to received emailed advices, the override email will get 500 emails)

  • These settings are not applied to DocOrigin Forms with Tyler Forms. Those settings are built into the Form and applied automatically.Â