Tyler Content Manager web service call encountered Method putDocuments2 throws tyler.empire.search.SearchException Failed to create full text search index for DocXXXX



Description of Issue

Site has Elastisearch ( Full Text Index) enabled and cannot save, scan or attach to TCM



Context
  • Munis

  • Enterprise ERP 

  • TCM

  • Scanning

  • Document Attach



Cause

The Elasticsearch DB has been put into Read Only Mode



Resolution

Tyler Hosted, please reach out to TSM SaaS Support.
Self-Hosted please complete the following steps:

  1. Connect to TCM App server

    1. Navigate to E:\Elastic Search\elasticsearch_TylercmXXXX_<ENV><SearchPort>\config\

      1. Right-click on the EnableESIndexScript.ps1 file and select Run with Powershell

        1. The run will show the PowerShell application briefly then close itself out.



Additional Information

The drive holding the search DB (E: for SaaS) must have at least 5 gb free or it will go into read only mode.

Powershell script will fail if the Elasticsearch service is stopped or renamed incorrectly