Integrations Failing in Time and Attendance due to Inactive Enterprise ERP Services

Description of Issue

When attempting to run integrations in a non-production environment, the following error is received:

"Error occured: java.lang.nullpointerexception: cannot invoke "org.springframework.http.responseentity.getbody()" because "webresponse" is null"

When checking the application log of Time and Attendance, the following error was observed:

Could not connect to web service! 503 Service Temporarily Unavailable: "<html><EOL><EOL><head><title>503 Service Temporarily Unavailable</title></head><EOL><EOL><body><EOL><EOL><center><h1>503 Service Temporarily Unavailable</h1></center><EOL><EOL></body><EOL><EOL></html><EOL><EOL>"
A fault was returned from the SOAP response (503)Service Temporarily Unavailable net.executime.dataimport.MunisWebServiceTokenAuthentication (default task-127) Token validation ERROR.  URL:https://[clientFQDN]/[instance]/munis/gas/svc/ws/r/mugws//spwshdlr net.executime.dataimport.AbstractWebServiceDataImport (default task-127) java.lang.Exception: A fault was returned from the SOAP response (503)Service Temporarily Unavailable

Context
  • Time and Attendance

  • EERP

  • Tyler Connectivity

  • Integrations

  • Harness

  • Application log

  • AWS

Cause

The connection is not working due to the Enterprise ERP services being unavailable for a non-production environment. Non-production AWS servers go inactive when not in use.

Resolution
  1. Log into Hub for the affected environment to wake the non-production services

  2. Retest the Time and Attendance-Enterprise ERP connectivity

Additional Information