When converting Overtime to Comp time the entry deletes itself

Description of Issue

Client reports that when one of their employees is trying to convert their Overtime to Comp time that was splitting from a Holiday, the Holiday entry deletes itself

Context
  • ExecuTime

  • Time & Attendance

  • Overtime

  • Comp Time

  • Holiday

Cause

The issue is when the employee converts the overtime that is splitting from the holiday its resetting the holiday to pending which is why the employee no longer sees it on their time card. The pending holiday in Manage Time off is still viewable.

Resolution

The resolution is to change the holiday pay code to not allow overtime to split from the holiday entry.

  1. Login to Time & Attendance with Admin role

  2. Click System Admin

  3. Click Master File Management

  4. Click Pay Codes

  5. Click the Pencil Icon for the holiday pay code

  6. Uncheck Allow overtime to be split from this pay code

This will make it so overtime will no longer split from the holiday code and will prevent this issue from happening again.

Additional Information