How to create GB Invoice TCM Attachments via Readyforms

Description of Issue

How to Archive Invoices?

Do not see invoice attachments in TCM

Context
  • Readyforms

  • Print Invoices

  • TCM Attachments 

Cause

Users who are expecting to see GB Invoice TCM attachments will need to review the following Prerequisites; 

  • Invoices are processed using Readyforms. 

  • Readyform Delivery Definition has a step with the option for Archive checked. 

  • Invoices have been output using the Print Invoices with Create Export File and XML options chosen.

Resolution

To set up Readyforms Delivery Definition for archiving. 

  1. Navigate to General Revenues > General Billing > Invoice Processing > Print Invoices.

  2. Click Readyforms Delivery Definitions in the top menu.

  3. Search for an existing delivery definition or click add to add a new one.

  4. click Accept.

  5. Under Steps, click Add

  6. Enter a name for the step. eg. 'Archive'.

  7. Check the box for the template being used.

  8. Check the box for Archive. 

  9. Select General Billing Invoice in the Document Type field.

  10. Click Accept.

  11. Click Back to return to Print Invoices.

  12. Click Define and populate fields with relevant invoice information.

  13. Select options for Create Export File and XML.

  14. Click Accept

  15. Click the Readyforms button in the top menu.

  16. Choose the RF template with the Archive step

  17. Click ok and proceed with output options

Once output is complete PDF attachments should be available in Invoice Inquiry. 

Additional Information

Please reach out to support for additional information.Â