Forms Error API Version Not Detected
Description of Issue
When trying to process or print documents with Forms, you get the error API Version Not Detected
Context
- ReadyForms
- Forms
- Unable to print POs with ReadyForms
Cause
EERP is unable to successfully connect to the Forms endpoint
Resolution
- Attempt to browse to Forms Administration page to verify if the Forms website is operational
- Launch Enterprise Forms Administration from Hub menu, or browse to URL (ex:Â https://tylertown.com/prod/readyforms/administration)
- If you receive an SSL error, follow Update SSL Certificate in IIS
- If the site is working, verify what the Forms endpoint URL is set to in the EERP environmentÂ
- With an administrator account, open Diagnostic Utility and Run-Time Information (System Administration > General Administration > Diagnostic Utility and Run-Time Information)
- Click the Server tab
- Scroll down to the bottom to locate TYLERFORMS_URL
- Example URL: https://tylertown.com/prod/readyforms/api
- Verify what URL should be set to
- In Tyler Deploy, under Product Configurations, select ReadyForms, then select the appropriate environment
- Check off Show Advanced
- Scroll down to locate API Web App URL
- If URL does not match what is set in EERP, please contact TSM Support to have it updated.
Additional Information