Forms Error API Version Not Detected

Description of Issue

When trying to process or print documents with Forms, you get the error API Version Not Detected

Context
  • ReadyForms
  • Forms
  • Unable to print POs with ReadyForms
Cause

EERP is unable to successfully connect to the Forms endpoint

Resolution
  1. Attempt to browse to Forms Administration page to verify if the Forms website is operational
    1. Launch Enterprise Forms Administration from Hub menu, or browse to URL (ex: https://tylertown.com/prod/readyforms/administration)
  2. If you receive an SSL error, follow Update SSL Certificate in IIS
  3. If the site is working, verify what the Forms endpoint URL is set to in the EERP environment 
    1. With an administrator account, open Diagnostic Utility and Run-Time Information (System Administration > General Administration > Diagnostic Utility and Run-Time Information)
    2. Click the Server tab
    3. Scroll down to the bottom to locate TYLERFORMS_URL
      1. Example URL: https://tylertown.com/prod/readyforms/api
  4. Verify what URL should be set to
    1. In Tyler Deploy, under Product Configurations, select ReadyForms, then select the appropriate environment
    2. Check off Show Advanced
    3. Scroll down to locate API Web App URL
    4. If URL does not match what is set in EERP, please contact TSM Support to have it updated.