Delete Time Entries prompt when deleting a payroll



Description of Issue

I deleted a payroll and now my Time Entry batches are gone with pending time entry records. 

Context
  • Munis
  • Payroll Start and Status
  • Time Entry
Cause

When a payroll is deleted, the user gets a prompt with the option to delete all associated Time Entry batches for that run and warrant. If the batches are deleted, all pending Time Entry records are also deleted.

Resolution

If No was selected when deleting the payroll to prompt, Delete Time Entry - Do you wish to delete the Time Entries for this payroll? :

  1. Go to Payroll Start and Status. (Payroll>Payroll Processing>Payroll Start and Status)
  2. Click Start. Click Start. Define the Run, Warrant, Start and End dates identical to the payroll that was deleted. Define Check Date. Click Accept. Click Return. 
  3. Go to Time Entry. (Payroll>Payroll Processing>Time Entry Processing>Time Entry)
  4. Click Search. Click Accept. 
    1. All the batches should pull back in for this payroll.

If Yes was selected when deleting the payroll to prompt, Delete Time Entry - Do you wish to delete the Time Entries for this payroll? there are two options:

  • Manually enter back in all the batch information.
  • Have IT or SaaS support copy a back up from previous day of Live to Test or Train. Then export out the Pending Time Entry records and import them into Live. 
Additional Information