/
Installing the Dynamsoft Twain Scan Driver via group policy

Installing the Dynamsoft Twain Scan Driver via group policy



Description of Issue

When Content Manager is upgraded there may be a need to update the Dynamsoft Twain Driver that is used for scanning directly to CM. 
The driver can be  manually installed on each workstation if user permissions allow, or via group policy if the users do not have access to download via their PC.



Context
  • EERP

  • HTML

  • Web Browser

  • CM

  • Content Manager

  • Scanning

  • Dynamsoft

  • Twain

  • MSI



Cause

After an upgrade a updated Twain Driver may need to be installed in order for scanning directly to CM to function.

Here is a link of the Available CM versions and the compatible version of the Dynamsoft driver that is recommended to be installed if scanning directly to TCM: Content Manager Release Lifecycle Community page




Resolution
  • On-Prem  admin users can access the msi file after TCM has been upgraded on their TCM server through the example path: Program Files\Apache Software Foundation\<TomcatFolder>\webapps\<WebappFolder\viewer\lib\dynamsoft\dist\DynamsoftServiceSetup.msi

  • SaaS Hosted admin users can request the driver be installed via the MSI package following the upgrade if the site scans directly to TCM. Please reach out to TSM SaaS if you are needing an updated MSI and where not provided with one.



Additional Information

Only one version of the Dynamsoft Driver should be installed on a sites CM server as the drivers are not backwards compatible and will not work with other versions.
If CM versions are installed that require different drivers we recommend upgrading CM for all environment to the same version.
If this is not feasible then we recommend only installing the driver manually via an individual machine for a few machines for testing purposes only.











Related content

Installed Scanner on Workstation is not being Recognized by Content Manager
Installed Scanner on Workstation is not being Recognized by Content Manager
More like this
How to install Dynamsoft Service on workstation for use with CM scanning from EERP
How to install Dynamsoft Service on workstation for use with CM scanning from EERP
More like this
Upgrade Content Manager using Tyler Deploy
Upgrade Content Manager using Tyler Deploy
More like this
TCM Supported Scanners
TCM Supported Scanners
More like this
TCM Provider Unable to Load Sources for Selected Provider
TCM Provider Unable to Load Sources for Selected Provider
More like this
CM Batch Scanning - Source drop down menu is empty and seeing message no scan source selected
CM Batch Scanning - Source drop down menu is empty and seeing message no scan source selected
More like this