Installing the Dynamsoft Twain Scan Driver via group policy



Description of Issue

When TCM is upgraded there may be a need to update the Dynamsoft Twain Driver that is used for scanning directly to TCM.  The driver can be  manually installed or via group policy if the users do not have access to download via their PC.



Context
  • TCM

  • CM

  • Tyler Content Manager

  • Content Manager

  • Scanning

  • Dynamsoft

  • Twain

  • MSI



Cause

After an upgrade a updated Twain Driver may need to be installed in order for scanning directly to TCM to function.

Here is a link of the Available TCM versions and the compatible version of the Dynamsoft driver that is recommended to be installed if scanning directly to TCM: Content Manager Release Lifecycle Community page




Resolution
  • On-Prem  admin users can access the msi file after TCM has been upgraded on their TCM server through the example path: Program Files\Apache Software Foundation\<TomcatFolder>\webapps\<WebappFolder\viewer\lib\dynamsoft\dist\DynamsoftServiceSetup.msi

  • SaaS Hosted admin users can request the driver be installed via the MSI package following the upgrade if the site scans directly to TCM. Please reach out to TSM SaaS if you are needing an updated MSI and where not provided with one.



Additional Information
  • Only one version of the Dynamsoft Driver should be installed on a sites TCM server as the drivers are not backwards compatible and will not work with other versions. If TCM versions are installed that require different drivers we recommend upgrading TCM for all environment to the same version. If this is not feasible then we recommend only installing the driver manually via an individual machine for a few machines for testing purposes only.