Clicking on the paperclip from any EERP program screen does not launch the Content Manager HTML viewer window

Description of Issue

Clicking on the paperclip from any EERP program screen does not launch the CM/HTML viewer window. No error message is presented.

Context
  • EERP

  • Munis

  • CM

  • Content Manager

  • HTML

  • 2023.1.14

  • 2023.2.8

Cause

This behavior affects EERP Clients who upgraded to CM versions 2023.1.14 or 2023.2.8 
TCM 2023.1.14 and 2023.2.8 deployments are sometimes not properly populating the 'Integrated Viewer' setting within the TCM Full Client to HTML

Resolution

If Content Manager was not recently upgraded, please ask users to clear browser cache and try again. Master Article - Clear Browser Cache
Otherwise, please complete these steps:

  1. Log into the TCM Full Client using an account with Admin rights

    1. How to Access and Launch the TCM Full Client 

  2. From within the TCM Full Client, click on the Administration Menu button at the bottom left

  3. Click on System Setup in the left-hand side menu

  4. Click on the Content Manager Configuration option all the way at the bottom of the menu that popped up

  5. Expand the dropdown box for Integrated Viewer, then select HTML 5 

  6. Click OK

  7. Click on System Status (stoplight icon) in the top menu banner of icons

  8. Click Clear Cache from the right-hand menu buttons

    1. Disregard this prompt: Unable to query DB locks (most likely due to access denied, check the logs) Unable to query DB locks mostly likely due to access denied - check the logs

  9. Click Initialize Service from the right-hand menu buttons

  10. Minimize the Full Client window and navigate back to Tyler Hub to test the Paperclip functionality in EERP

    1. You can also test by retrieving a report from the Saved Reports module

      1. Open Saved reports > Retrieve tylerCM > Accept

If you need assistance completing the steps please create a case for Support to assist.

Additional Information

Error messages that will display in the Content Manager Database Log located under the stoplight/System Status button:

tyler.empire.security.SecurityManagerException: user '!munis' not found, tyler.cm.viewer.hashedlink.ViewerURLGeneratorException: tyler.empire.security.SecurityManagerException: user '!munis' not found Thu Sep 14 10:19:20 EDT 2023 ERROR [tyler.cm.viewer.hashedlink.ShortenerWebService] [https-openssl-nio2-443-exec-11] [munistcmprod] [munis] tyler.cm.viewer.hashedlink.ViewerURLGeneratorException: tyler.empire.security.SecurityManagerException: user '!munis' not found

Â