Change the Owner On a Single Bill

Description of Issue

Tax bill(s) were created with the incorrect owner or the owner on a tax bill(s) needs to be changed. 

Context
  • Property Tax Billing 
  • Bill Adjustments (txblgnmt)
Cause

The owner of a bill is incorrect or has changed. 

Resolution
  1. Navigate to the Bill Adjustments program either by searching or using the following path: Property Revenues > Property Tax Billing > Region > State > Collection Processing > Bill Adjustments
  2. Click Search. 
  3. On the next screen, click General. 
  4. Enter the Bill number, AR category, and Year of the bill that needs to be changed. 
  5. Click Accept. 
  6. Click Update and change the Owner customer number to the new owner's customer number. If a new customer record needs to be created for the new owner, please follow the steps outlined here to add a new customer: Add a New Customer
    1. The Field Help in the Owner field will allow an advanced search of the new owner's customer number.
  7. Click Accept.
  8. The bill now has a new owner. Repeat steps 2-7 for each bill as necessary.
Additional Information
  • If the owner of record (the owner of a property as of January 1st of that tax year) needs to be updated, please follow the steps outlined here: Change the Owner of Record Listed on a Bill
  • For all resources related to owner maintenance on tax bills, please see: Change the Owner on a Tax Bill
  • If further assistance is needed, please contact Tax Support for the appropriate region.Â