Splitting Documents message displays in HTML browser when opening TCM from Munis





Description of Issue

Splitting Documents message displays in HTML browser when opening TCM from Munis



Context
  • EERP

  • Munis

  • Content Manger

  • Tyler Content Manager

  • CM

  • CM HTML Viewer



Cause

The HTML browser enforces single attachment mode.  Before HTML, the java client would allow more than one file attachment to be saved to one metadata record.
When there is more than one attachment file saved with a data record in TCM, and a user opens TCM from Munis in the web browser, the splitting attachments process gets called to split each file attachment out into it's own data record.
In CM versions 2021.3 and older, there was a bug in TCM causing that process to hang, and the HTML viewer to continually display the Splitting Documents message. 



Resolution

This issue has been fixed in TCM codes 2021.3/+. Please update TCM to 2021.3 or higher (it is always recommended to patch TCM to the latest code available at that time).

  • If you are using Tyler Deploy, feel free to update TCM to the latest code.

  • If you are not using Tyler Deploy, please contact TSM Support to complete the update. 



Additional Information