When trying to dismiss alerts, they do not clear even with refresh



Description of Issue
  • Tyler Hub alerts need multiple attempts to clear

  • Dismissing Alerts from the Hub card records were updated but the record count takes several minutes to update. 

To replicate:

1. Create alert(s) in EERP
2. Select Alert card to display Active Alerts
3. Check off alerts to dismiss. 
4. Select Dismiss. 
5. Select Dismiss in pop up to confirm dismiss action


Message at the bottom of the screen indicates number of updated items
Alert(s) still display as Active (or Acknowledged, if they were acknowledged first) and the Alert count on the front of the card is not updated. 
Refresh browser and manually refresh card - still no change. 
Update occurs several minutes following the dismissal action. 



Context
  • Munis

  • Tyler Hub

  • Alerts

  • Enterprise ERP

  • Hub 2021.4.4. - 2021.5.4



Cause

Delayed update possibly caused by webservice



Resolution

HUB-6064 is open with HUB Development to address the webservice delay occurring with alert and notification cards when the pending actions are dismissed.

The current best practice is to acknowledge the alert. The acknowledgment will update the alert immediately with Acknowledged to indicate that the alert has been responded to, then dismiss the alert. There will still be a delay in the alert update of the alert to dismissed and that is what the above work ticket will address. 



Additional Information