Cannot Search by Unpaid Balance Range in Bill Inquiry
Description of Issue
Searching by Unpaid Balance range in Bill Inquiry does not work. When attempting to search by Unpaid Balance range, the error, Searching on the unpaid balance range you specified could be very slow. Please modify your search to identify a range like 0.01 to 99999999999.99 or specify a property or customer information to narrow your search. is received.Â
Context
- Accounts ReceivableÂ
- Property Tax BillingÂ
- General BillingÂ
- Community DevelopmentÂ
- Utility BillingÂ
- Bill Inquiry (arbilinq)Â
Cause
The criterion entered is too broad. Bill Inquiry is not designed to handle a request to find all bills within a certain unpaid balance range. Larger queries like this are beyond the scope of this program. When a search criterion is entered that is identified as too large for the program to satisfy efficiently, an error is displayed.Â
Resolution
- Unpaid Balance range can be entered when making a search in Bill Inquiry, but further details will need to be provided. Entering a Year and Category may narrow the search sufficiently for the program to execute the query, but if the error still displays, additional criterion like Parcel, Customer Name, or Address will need to be entered. Modify the search by providing additional information until the search can be performed successfully.
- There was a prior defect that prevented users from searching within the unpaid balance field regardless of the criteria provided. This has been corrected with an update. If this field is always greyed out, make sure recent updates have been installed.
Additional Information
- Bill Inquiry is an inquiry only program designed to provide in-depth information for a single or few records.Â
- If a larger data search needs to be executed, consider utilizing one of the reporting programs that are designed specifically for this purpose, like the Detail Receivables by Date.Â
- For additional information about the Bill Inquiry program, please see: Master Article - Bill Inquiry
- For further assistance, please contact the appropriate support team based on the category of bills being reported on.Â