Bill Inquiry History including duplicate system generated Adjustments and MIC Corrections for General Billing Invoices after migration



Description of Issue

After migrating from 11.3, some GB Invoices have more Adjustments than expected in the History within Bill Inquiry. In addition to these extra Adjustments, they are accompanied by a MIG Correction Adjustment to undo those adjustments. 

Duplicate adjustments were created by the migration



Context
  • General Revenue

  • General Billing

  • Accounts Receivable

  • Migration

  • Invoice Inquiry



Cause

The Migration generates duplicate Adjustments in the following scenario: After an amount change is made to an invoice, a second adjustment is made to add a new Charge line within the same entry date, but with different Reason codes. The Migration then recognizes the Bill amount does not match the Adjustment activity audit, so a MIC Correction is created to undo the duplicate adjustment. The Invoice remains balanced, but the History in Bill Inquiry will show the unnecessary activity. 



Resolution

By design, the Migration will create an Adjustment in the Bill Inquiry History tab to reflect every Invoice Audit adjustment that exist. If the Bill Inquiry history is not accurate, first compare the Adjustment activity shown in the Audit button within Invoice Inquiry, before contacting support. Note: not all visible activity in Bill Inquiry is also stored in the Audit in Invoice Inquiry, since it is reserved for adjustment activity only. Example, MIG Adjustments, ACC Accrued Interest, Payments, etc.

  • Navigate to General Revenues > General Billing > Invoice Processing > Invoice Inquiry

  • Click Search to find the desired Invoice

  • Click the Audit button

  • Compare Adjustment activity to Bill Inquiry activity


Development is currently researching an issue where duplicate adjustments are created that are then adjusted off by a MIG Correction. Install MUN-441264 once available. Contact Munis Revenue Support if experiencing this



Additional Information

In the previous 11.3 version of Munis, GB Invoice Adjustments reside only in the Audit button within Invoice Inquiry, Whereas with other billing categories the adjustment activity is stored and visible in Bill Inquiry's History tab. Any sort of adjustment change to the invoice, such as a price, quantity/count, discount, or even adding an additional charge line, would create an audit record with the Invoice. These adjustments are not visible in Bill Inquiry under the History tab. After migrating to 2017.1 or higher, the migration is designed to create those Adjustments in Bill Inquiry. In some cases, a Migration MIG Adjustment is needed to correct any gaps in the audit. These are typically created if an Invoice was out of balance or missing an adjustment transaction overtime.Â