Timesheet Entry Pay Code Not Available



Description of Issue

Timekeepers are unable to access base pay codes for users via Timesheet Entry menu



Context
  • Time and Attendance (ExecuTime)

  • Time Sheet Entry

  • UI Environment Flags



Cause

UI Environment flag to enable start/end time not enabled  



Resolution

Check here first: Employees Can Not Enter Time for a Pay Code in Timesheet Entry or Clock in and Out in Time and Attendance If still unable to see the pay code:

  1. Navigate to System Admin > UI Environment Flags

  2. Check Enable start/end time on timesheet option with the Application Control section.

  3. Click Save.



Additional Information

When a pay code is configured with both Allow for Clock In/out Transaction and Edit of Timesheet in the Pay Code setup, the clock in/out functionality takes precedence over the timesheet functionality.

This prevents the code from being available unless the UI flag mentioned above is enabled with a check mark.