Account Inquiry Journal Option Error - Access denied due to program security established by the System Administrator


Description of Issue

Account Inquiry viewing the detail of an account. When the Journal option in the ribbon is selected the following error is received:

Access denied due to program security established by the System Administrator

Context
  • Account Inquiry
  • Journal Inquiry/Print
Cause

User did not have menu access to the Journal Inquiry/Print program.

Resolution

To resolve, the user will need menu access to the Journal Inquiry/Print program.

System Administration > Security > User Attributes

  1. Search for the User Id
  2. Select the role which grants menu access to the user
  3. Hit the Edit Role option at the bottom
  4. Select the Menu Security tab
  5. Double click on the menu path to get to the program (Financials > General Ledger Menu > Journal Entry/History > Journal Inquiry/Print)
  6. Hit the Edit option and check the box to add that program to the user's menu

Once the menu option is added, they will need to refresh the Tyler Menu or log out and back in to see the updated program.

Additional Information

The menu access needed can vary depending on the journal source type the user is trying to access. Review the browser URL to determine what program is being opened when the error is encountered. 

Master Article - Access Denied - Access denied due to program security established by the System Administrator