Time and Attendance SSRS Report not running

Description of Issue

User is receiving the generic application error when trying to run the Access Security and Time Summary Report:

The report is unable to run. Please check the connection to the Reporting Server within System Configuration > Reports. Ensure the connection is working and also ensure all reports are correctly deployed to the report server.

The following error is thrown in the SSRS Report Server Log file:

Microsoft.ReportingServices.Diagnostics.Utilities.RSException: The Hidden expression for the tablix 'Details' contains an error: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. ---> Microsoft.ReportingServices.ReportProcessing.ReportProcessingException: The Hidden expression for the tablix 'Details' contains an error: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed. webserver!ReportServer_0-6!25ec!05/17/2024-10:08:17:: e ERROR: RS.Server.HttpHandlerError {"shortHttpDescription":"Reporting Services Error","code":"500","path":"reportServiceHandlerWriteError","exceptionType":"Microsoft.ReportingServices.Diagnostics.Utilities.RSException"} appdomainmanager!ReportServer_0-6!f90!05/17/2024-10:08:17:: e ERROR: Remote certificate error RemoteCertificateChainErrors encountered for url https://vortex.data.microsoft.com/collect/v1.

When browsing to that URL noted in the error log, there is a certificate error and the end user is greeted with a FortiGuard Intrusion Prevention - Access Blocked message stating that the web page is blocked.

Context
  • ExecuTime

  • Time and Attendance

  • SSRS Report Server

  • FortiGuard or equivalent

Cause

FortiGuard or equivalent is blocking a Microsoft URL that the SSRS Report Server is using in the report process for the reports.

Resolution

*Note: There is a successful connection to the SSRS server from the application and other reports are able to run without issue. This only effects certain reports.

  1. Client must allow traffic through FortiGuard to the Microsoft URL (https://vortex.data.microsoft.com/collect/v1) so that the SSRS Report Server can generate the report.

  2. Re-run the report in Time and Attendance to ensure it is now successfully generated.

Additional Information