Okta 400 Bad Request Identity Provider OIDC Error Code invalid_social_token

Description of Issue

When trying to log into any Tyler products, all users receive the following error message:

400 Bad Request

Your request resulted in an error. Could not acquire access token from authorization code.

Identity Provider OIDC Error Code invalid_social_token. 

Context
  • TID-W
  • Okta
  • Azure integration
  • Entra ID
Cause

Azure/Entra or Google client secret expired

Resolution
  1. Obtain new client secret
    1. Generate a Client Secret for Microsoft Integration with OKTA
  2. Contact support to get a Reestablish Federation email
    1. How to renew expired certificate or secret using Reestablish Federation
  3. Or provide client secret to support via Kiteworks
Additional Information