Unable to add invoice account error in Invoice Entry and Proof

Description of Issue

After deleting the GL Account(s) for a Detail Line on a General Billing Invoice in Invoice Entry and Proof, attempting to add a GL Account to the Detail Line results in an Unable to add invoice account. error.

Context
  • General Billing
  • Invoice Entry and Proof (gbinvent)
  • GL Detail
Cause

The cause of this issue is currently unknown. 

Resolution

Development is researching this issue.

As a workaround, instead of adding the GL Account(s) to the Detail Line, delete and re-add the Invoice following these steps: 

  1. Resume the batch in Invoice Entry and Proof: Resume a Batch in Invoice Entry and Proof
  2. Click Browse. 
  3. Find the Invoice in the list. 
  4. Click the Invoice. 
  5. Click Delete.
  6. A message appears: Are you sure you want to delete this record from the database? 
  7. Click Yes to delete the invoice. 
  8. Re-create the invoice being sure to either use the default GL Accounts or update the GL Accounts instead of deleting them. (Guidance for creating General Billing Invoices can be found here if needed: How to Create General Billing Invoices)
Additional Information

Additional resources for working in Invoice Entry and Proof can be found here: Master Article - Invoice Entry and Proof