Failed to get document list because an error has occurred Error querying Elastic Search database response code 500

Description of Issue

When clicking the paperclip and alert pops up: failed to get document list because an error has occurred: error querying Elastic Search database, response code=500

Error when trying to view or attach new documents to the TCM document Viewer.

Context
  • Content Manager
  • CM
  • Tyler content Manager
  • TCM
  • Mappings
  • Document Mappings
  • Paperclip
  • Attachments
  • HTML Viewer
  • Document Viewer
Cause

A document mapping is causing a search conflict.

Resolution
  1. When launching TCM through the Enterprise ERP program, use the dropdown arrow next to the paperclip and select Document Mappings
    1. There may be an error that pops up when launching the Document Mappings window: Tyler Content Manager web service call encountered: Method 'getDocumentCount' throws: tyler.empireempire.search.SearchException: Unable to search. Click Continue and proceed with these steps
  2. Double-click on each mapping to launch it into the TCM document viewer. If the error populates for a specific mapping, that one needs to be removed from the TCM launch.
    1. Remove unwanted TCM mappings

If you do not have permissions to maintain mappings, you should be able to view or attach new documents by using the specific document mapping type as pertinent to your desired attachment and double-click to launch the viewer with the single mapping ad attach the document as normal.

How to grant or limit permissions to Maintain Munis to TCM Mappings

Additional Information

Sometimes the individual mapping will not cause the same error when launching separate from other mappings. Contact Support for further assistance if this happens.