Cashiering Not Purging Log Files

Description of Issue

Cashiering is not purging the log files according to the schedule that we have setup.

In Cashiering Administration > Settings > General, under Logging, Maintain logs for and Clear logs at are both set.

Context
  • Cashiering logs
  • Purging Cashiering logs
  • Cashiering logs not deleting
  • Log retention
  • Cashiering log messages not deleting
Cause

The Cashiering Worker Service is attempting to perform a full-wipe of the table in a single SQL transaction, which usually locks up the database and times out when the table is too large.

Resolution
  • CSH-12039 was generated with Deployment to change the Log Purge job to perform the delete in batches.
  • Update to Cashiering version 2021.9 or higher.
Additional Information

Cashiering Logging Levels

  • If a workaround is needed before the update can be applied, you can try expanding the time range and do the purge slower/in smaller chunks.
    • If set for 1 day, there may be a lot of data to clear. Start by keeping a few years and working down to the desired time range.
  • You can also contact Tyler Systems Management Support or log a case via the Online Support Client Portal to have the dbo.LogMessages table cleared.
    • Please note this will need to be done at a time when users are out of the system.