Misc Items Codes Not Syncing from Munis to Cashiering



Description of Issue

The Miscellaneous Item Codes from MUNIS are not synching to Cashiering. The sync to external systems does not work.

To attempt to sync the codes, navigate to Cashiering Administration > Payment Types > click the 3 dots > click Misc Item Codes > click the Sync External Items  icon

Application logs may show one or more of the following:

  • Failed to sync external items

  • Sync External Items - SuperuserId not found for Munis



Context
  • Cashiering

  • Miscellaneous item codes

  • Charge codes



Cause

SuperuserID is not set for the Munis External System, or is not set correctly



Resolution
  1. Log into Cashiering with an administrator account

  2. Navigate to Administration > External Systems > Munis

  3. Click Edit

  4. In the Miscellaneous integration superuser field, enter the user name of the user who will serve in this role

    1. This is typically the web service user (Ex: wsuser)

  5. Click Save

  6. Navigate to Administration > Payment Types 

  7. Locate the payment type for which you would like to sync external system misc. item codes.

  8. Next to the payment type, click the 3 dots > click Misc Item Codes

  9. Click the Sync External Items  icon

  10. Refresh the page



Additional Information

Note: It might take a few minutes for the item codes to display. If they do not appear after a few minutes, refresh the screen. If they still don't display, exit the Misc. Item Codes page and then go back into the page. They should then display.

https://help.tylertech.com/TylerCashiering/HelpCentral_WV/TC/Content/Programs_AdditionalContent/What's%20New/2021.1/External%20Systems%20-%20Misc%20Custom%20Codes.htm?Highlight=misc%20item%20code