Payroll-Time Entry-Cannot delete Time Entry batch



Description of Issue

User does not see the Delete button in Time Entry to delete a batch. 



Context
  • Payroll

  • Time Entry

  • Roles

  • User Attributes



Cause

There are two permissions that allow users to delete Time Entry batches. One is for deleting their own batches, and the other is for deleting others' batches. Neither is enabled for the user's role. 



Resolution

If user should have this functionality, changes will need to be made by user with access to Security menu:

  1. Navigate to System Administration>Security>Roles.

  2. Search for the Role that gives the user Payroll access. 

    1. If not sure which role, go to System Administration>Security>User Attributes. Search for the employee and locate the role that lists Payroll under Grants Access To.

  3. Click the HR Management/Payroll folder.

  4. Click Update.

  5. Click Time Entry tab.

  6. Check off one or both of the following options:

    1. Delete own batches

    2. Delete other's batches

  7. Click Accept.

  8. Have user log out and log back in to see the changes. 



Additional Information