Wrong Pay Code Deafualting to Timesheet When Employee Clocks In

Description of Issue

When the user clocks in they noticed that the pay code that is set as their Default clock in/ out Pay Code on their Master File Profile is not defaulting on the Timesheet. The correct Pay Code does not appear in the Default Clock in/out Pay Code drop down any longer it is default to None. 

Context
  • Clock In/out

  • Timesheet Entry 

  • Pay Code 

  • EERP Payroll

  • Employee Job/Salary

Cause

The user no longer had access to this pay code in EERP Payroll (Munis) Employee Job/Salary.

Resolution

To verify the employee has access in EERP:

  1. Log into EERP and navigate to Employee Job/Salary (Human Capital Management>Payroll>Employee Maintenance>Employee Job/Salary)

  2. Click Search. Define the employee number, Search Criteria of Current then click Accept.

  3. If the Pay Code is in not in the employee's current set of Pays, it will need to be Added. 

    1. If the pay code is there but is inactive or end dated, it will need to be updated to Active or a valid end date. 

Once the user has access to the pay code in EERP, follow the steps below in Time and Attendance:

  1. Navigate to the users Timesheet Entry 

  2. Select the Refresh Pay Code, PL, and GL Cache button at the bottom right of the screen 

  3. Notice that the Pay Code in question no appears on the Timesheet

Set the correct Default In/Out code Pay Code on the Employees profile 

  1. Navigate to System Admin

  2. Select Master File Management 

  3. Select the pencil to edit the employee in questions 

  4. Select the Pay Properties tab 

  5. Select the pay code in question in the drop down for the Default Clock in/out Pay Code

  6. Select Save for current pay period 


Additional Information