Business License Expire Date field blank

Description of Issue

There is no date listed under the Expire Date field on the Dates/Other tab of the license in the Business Accounts program.

Context
  • Business Licenses

  • License Renewal

Cause

The license record was locked when the system attempted to update the date.

Resolution

Back out of the license in the Business Accounts program prior to printing renewals, generating AR and collecting payment on the license bill. Closing EERP programs using the X on the browser tab or the record can cause the record to remain locked for several hours.

Additional Information
  • Expiration dates will update either when Print Renewals and Gen AR are run or when the bill is paid in full.   If the license record is locked when the program attempts to update the date, the date will be left blank.

  • Expiration date setting are found in the Business License Settings > Additional Defaults tab > Update expire date when bill has zero balance.