Employees can still see SSNs in Time Entry History

Description of Issue

Users permissions do not allow viewing SSNs in any program, however in Time Entry History they are still able to see SSNs. They are unable to see SSNs correctly in Time Entry, Payroll and other reports. It appears they are only able to see SSNs in Time Entry History. 

Context
  • Payroll
  • Roles
  • User Attributes
  • Time Entry
  • Time Entry History
Cause

One or more roles still had Inquiry Only access for Employee Detail History Category Access instead of (Hide SSN) Inquiry Only.

Resolution
  1.  Navigate to Roles (System Administration>Security>Roles)
  2. Click Search.
  3. Search for the applicable Role that has Payroll access
  4. Navigate to the Yellow Folder on the bottom that says HR Management/Payroll  
  5. Under the General Tab check to see if the checkbox for View SSN on Reports is checked off. 
  6. Also check to see if the Role is set to be a Superuser under Payroll Superuser. 
  7. Next, Click on the Time Entry Tab and see if the checkbox View SSNs is checked off. 
  8. Lastly, navigate to Category Access Tab
  9. Check to see if the following are set to Hide SSN (Inquiry). Employee Detail History, Employee Master Main. 
Additional Information