Tyler Hub Redirects To Original IDP After Second IDP Is Federated In Okta Tenant



Description of Issue

The client has had a second IDP federated in their Okta tenant, but browsing to the Tyler Hub URL still results in a redirect to the original IDP which is restricting some users from being able to log in. 



Context
  • Tyler Hub

  • Tyler Deploy

  • Query String Parameters



Cause

Tyler Hub was deployed with an IDP ID value in the Query String Parameters field.  Addition of a second IDP requires that value to be removed from the Hub config, however a re-deployment of Hub with Query String Parameters field cleared out does not remove the value from the Hub config.



Resolution
  1. Locate the tidConfiguration.config file in the Hub code folder and back it up

    1. For an OnPrem installation this would typically be located in <drv>:\inetpub\tylerroot\<env_name>\hub

  2. Decrypt the file using Utilities in Tyler Deploy.  Set the Config section name value to tidConfiguration.

  3. Locate the tag query string params tag in the XML file and either remove the tag or REM it out, then save the file.

  4. Re-encrypt the file.

  5. Restart the Hub application pool.

  6. Close and re-launch your browser and test the Hub login again.



Additional Information

An IDP ID value for query string parameters in Tyler Hub can be useful when there is only one IDP federated in Okta, but the tag needs to be removed if there are multiple federations.

Please review the Master Article - Tyler Hub for all related topics.