/
Current owner not printing on MLC

Current owner not printing on MLC



Description of Issue

The current owner of a parcel is not printing on a municipal lien certificate (MLC). 



Context
  • MA Tax 

  • Municipal Lien Certificates (tmalienc) 

  • MLC



Cause

The owner selected when generating the MLC is the Owner of Record instead of the Current Owner or the current parcel has not been updated with the current owner. 



Resolution
  1. Navigate to the Municipal Lien Certificate program either by searching or using the following path: Property Revenues > Property Tax Billing > Northeast > Massachusetts > Collection Processing > Municipal Lien Certificate

  2. Click Define.  

  3. Make all usual selections and be sure to select Current Owner in Owner field. 

  4. Click Accept

  5. Generate the MLC (typically by clicking PDF, but printing method varies depending on what forms options are configured). 

  6. The current owner should print on the MLC. If it does not, then the current owner needs to be updated on the current parcel. 



Additional Information

If additional assistance is required, please contact Northeast Tax Support. 











Related content

Requestor Address Not Showing on Enterprise Forms MLC
Requestor Address Not Showing on Enterprise Forms MLC
More like this
How to update the collectors name on MLC
How to update the collectors name on MLC
More like this
Municipal Lien Certificate Includes Balances for Future Quarters
Municipal Lien Certificate Includes Balances for Future Quarters
More like this
Parcel not found message in Municipal Lien Certificate
Parcel not found message in Municipal Lien Certificate
More like this
Exemption amount is incorrect on MLC
Exemption amount is incorrect on MLC
More like this
MLC Enterprise form lacking 3x3 inch recording area required by the Registry
MLC Enterprise form lacking 3x3 inch recording area required by the Registry
More like this