Employee has two ME Retirement Maintenance records but only one Period Record is Generating in ME Retirement Report

Description of Issue

Employee with two ME PERS Maintenance records is only generating one ME PERS Retirement period record. 

Context
  • Payroll

  • Maine

  • ME Retirement Maintenance

  • ME Retirement Report

Cause

Employee's secondary ME PERS Retirement Maintenance record was missing defined pay types on the Pay Ranges tab.

Resolution
  1. Navigate to Human Resources/Payroll > Payroll > State Specific> Northeast > Maine > ME Retirement Maintenance

  2. Click Search and enter the Employee number to pull up the employee missing the record

  3. Navigate to the Pay Ranges tab on the employee record that is not generating a Period Record

  4. Select Update and enter the pays that are associated with the ME PERS position

  5. Select Accept to save changes

Once this update is complete navigate to the ME Retirement Report and Generate. 

Additional Information

Please begin transitioning to the new MainePERS Reporting program available in Version 2021.11 & Higher!

You will need to start with the MainePERS Reporting - Setup document to review and complete the required setup steps.  Once setup is completed, please review the MainePERS Reporting - Processing document for step-by-step instructions on the new program.  At that point, please Generate records in the new program and compare them to the records submitted from the old program for the same Reporting Month/Year.  If everything matches, begin using the new program.  Otherwise, please reach out to State Reporting Support for assistance with identified differences. 

As you make your way through the process of transitioning to the new program, please reach out to EERP State Reporting Support if you encounter a question, a concern, or something that feels cumbersome.  We look forward to your feedback and any additional improvements we can make!

State Reporting Support can be reached through the Tyler portal, by email to MunisStateReporting@tylertech.com, or by phone at 1-800-772-2260 x3827. 

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