Prerequisites for Creating Employee Insurance Bills with General Billing

Description of Issue
  • Need to know what the prerequisites are for running Create Employee Insurance Bills.
  • What setup is needed to run Create Employee Insurance Bills?
Context
  • Payroll 
  • General Billing
  • Employee Insurance Bills
  • Create Employee Insurance Bills (gbempins)
Cause

Need to fulfill the prerequisites for creating Employee Insurance Bills.

Resolution
  • Enterprise ERP Payroll must be fully implemented.
  • Retirees or Employees who are not receiving a paycheck and who are being billed for their insurance must exist in the Payroll Employee Master program with a Status of B - Benefit Only. 
    • To verify this, navigate to the Employee Master program either by searching or via the following path: Human Capital Management > Payroll > Employee Maintenance > Employee Master 
    • Click Search. 
    • Select B - Benefit Only from the Status dropdown. 
    • Click Accept. 
    • Employees that return are eligible for Employee Insurance Billing. 
  • Deduction Codes must exist for the insurance plans with the Calc Code 01 - AMT FROM DEDUCTION MASTER or 02 - AMT FROM EMPLOYEE DEDUCTION in the Deduction and Benefit Master program. 
    • To verify this, navigate to the Deduction and Benefit Master program either by searching or via the following path: Human Capital Management > Payroll > Payroll Setup > Deduction and Benefit Master 
    • Click Search. 
    • Select 01 - AMT FROM DEDUCTION MASTER and 02 - AMT FROM EMPLOYEE DEDUCTION from the Calc Code dropdown. 
    • Click Accept. 
    • Deductions that return are eligible for Employee Insurance Billing. 
  • Charge Codes must exist in the Current Year. The Charge Code's Code must match the value in the Deduction Code's Deduction field. For example, if the value in the Deduction Code's Deduction field is 2500, then the Charge Code's Code must also be 2500.
  • A Customer Type Code that is used for Employee Insurance Billing must exist in the Accounts Receivable Miscellaneous Codes program. 
    • To verify this, navigate to the Accounts Receivable Miscellaneous Codes program either by searching or via the following path: Property or General Revenues > Accounts Receivable > Setup > Accounts Receivable Miscellaneous Codes
    • Select Customer Type Codes. 
    • Review the various Descriptions and confirm that a Customer Type Code for Employee Insurance Billing exists.
      • (Note: The Description is informational only and can be any value. It will be used on the Customer records to mark them eligible for Employee Insurance Billing.)
    • If a Customer Type Code needs to be created, please see: Add a Customer Type Code
  • Corresponding Customer records for the Employees must exist in the Accounts Receivable Customers program. The Employee Number and Customer Type Code must be listed on the Customer record. 
    • To verify this, navigate to the Accounts Receivable Customers program either by searching or via the following path: Property or General Revenues > Accounts Receivable > Setup > Customers
    • Click Find in the ribbon. 
    • Enter the Employee Number in the Employee # field. 
      • If a Customer record returns:
        • Select the Other tab. 
        • Verify that the Customer Type Code is listed in the Customer Type field. 
          • If it is: 
            • The Customer is eligible for Employee Insurance Billing. 
          • If it is not: 
            • Click Update. 
            • Select the desired Customer Type Code from the Customer Type dropdown. 
            • Click Accept. 
            • The Customer is now eligible for Employee Insurance Billing. 
      • If a Customer record does not return: 
        • Enter the Employee's First and Last Name in-between asterisks, for example *FIRST LAST* in the Name field. 
        • Select the Use case-insensitive name and address search and Display only name and address in results (faster) options underneath the Search Options heading. 
        • Click Accept. 
        • If no records return, try other search combinations like Address and Phone number using the Find option. 
        • If no search options return results, then a Customer record needs to be added, which can be accomplished by following the steps outlined here: Add a New Customer
          • If adding a new Customer, be sure to enter the Employee Number in the Employee # field and select the desired Customer Type Code from the Customer Type dropdown on the Other tab. 
  • If all of these prerequisites are met, then Create Employee Insurance Bills can be run! 
Additional Information
  • For assistance setting up Employees or Deduction Codes, please contact Payroll Support. 
  • For assistance setting up Charge Codes, Customer Type Codes, or Customer records, please contact General Billing Support.Â