General Billing Invoice not archiving to TCM with ReadyForms

Description of Issue

When attempting to archive a General Billing invoice to Tyler Content Manager with ReadyForms, the invoice does not archive. 

Context
  • General Billing
  • ReadyForms
  • Tyler Content Manager (TCM)
  • Print Invoices (gbinvprt)
Cause

This issue can have many causes. A known cause is that the Customer Name associated with the invoice has blank space or special characters. 

Resolution
  1. After selecting the desired invoices in the Print Invoices program, select ReadyForms in the ribbon.
  2. In the Output window, choose the desired Delivery Definition. 
  3. Select Preview Documents. 
  4. Click OK.
  5. When the ReadyForms Preview window opens, click the dropdown arrow under the Document Number field in the Meta Data section on the bottom left. 
  6. Review the meta data Values for each of the Keys listed. Make sure that there are no extra spaces or special characters, especially in the CustomerName key. 
    1. If there are extra spaces or special characters in the CustomerName Key, then follow the steps outlined here to update the Customer Name and remove the extra spaces or special characters. 
Additional Information