After upgrading to TA 2024.1 or higher Timeclocks displaying Server Unreachable

Description of Issue

Timeclocks stop communicating to application with Server Unreachable when utilizing a self-signed certificate with TA

Context
  • TA

  • Time and Attendance

  • TouchTime

  • Time clock

  • Timeclock

  • ExecuTime

Cause

TA 2024.1+ now has Strict Transport Security or HTTP → HTTPS rewrite built into the application. Clients utilizing Self-Signed certificates and have enabled the HTTP protocol on Timeclock Configuration in the application will experience this issue because the clocks will not trust the certificate. The new security protocol causes a rewrite loop with the application, thereby denying/disabling the API call that clocks use to communicate with the application. 

Resolution
  1. Purchase and utilize a public CA certificate (e.g., Digicert, GoDaddy, etc.)

    1. SSL Certificate Basics and FAQs

  2. Update certificate for application: How to apply Time and Attendance SSL certificate

Work around:

Please Note: This workaround is a temporary solution and will be overwritten/undone upon next deployment/update from Tyler Deploy. The long-term solution is to purchase and utilize a certificate from a public CA authority

  1. Connect to the Time & Attendance application server

  2. Navigate to [Drive:\]{InstanceName}\WildFly\standalone\configuration\standalone.xml

  3. Edit the TA configuration file with a text editor such as Notepad++

  4. Search for <rewrite name="http-to-https"

  5. Comment that line out

    1. Option 1: Add <!-- to the beginning of the line and add --> to the end

      1. Example: <!-- rewrite name="http-to-https" target="https://Some.FQDN.here:7120%U" redirect="true" /  →

    2. Option 2: Highlight the line, right click, select Toggle Single Line Comment

  6. Save the standalone.xml (Click Save or CRTL+S)

  7. Restart the TA application

    1. How to restart the ExecuTime Service - OnPrem

Additional Information