Time and Attendance Update Failing at Verify ExecuTime step in Tyler Deploy

Description of Issue

Error occurred when trying to upgrade Time and Attendance. The Verify ExecuTime step states the following error:

Certificate path exists: [Drive]:\CertificateFolder\ETCert.pfx
Invalid certificate password for ETCert.pfx

Context
  • Time and Attendance

  • Certificate

  • ExecuTime

  • Tyler Deploy

  • Invalid Password

Cause

The issue is due to the password associated with the certificate does not match the password in the ExecuTime (Time and Attendance) configuration page in Tyler Deploy.

Resolution
  1. To extract the password for the existing certificate, navigate to [DRIVE:\]{InstanceName}\WildFly\standalone\configuration

  2. Open the standalone.xml file in Notepad++

  3. Search for <ssl> (it is right near the top)

  4. Inside the <ssl> tag you have a keystore tag, by default it looks like this:

    1. <keystore path="ETCert.pfx" relative-to="jboss.server.config.dir" keystore-password="password" alias="server" key-password="password" generate-self-signed-certificate-host="localhost"/>

  5. Copy the value that's in the quotations next to keystore-password

    1. Ex: keystore-password="password123"

  6. Update the password in the Tyler Deploy ExecuTime Configuration. See following article on how to update the password field in Deploy

    1. How to update the SSL Certificate Path and SSL Password in Tyler Deploy for Time and Attendance environments

  7. Redeploy the upgrade for Time and Attendance.

Additional Information