All Contacts Being Charged as Non-Residents

Description of Issue

All contacts, in the citizen portal or the admin portal, are receiving the Non-Resident rate for all new transactions. After saving a contact with an address that with 100% certainty is within the boundary layer set up in ArcGIS, they are listed as Resident - No. ArcGIS settings have been verified. In Administration > System Setup > System Settings, the residence verification process kicks off after clicking Save, but never moves past contact 0/####. 

Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation

  • ArcGIS

  • Residency

  • Residence Verification

Cause

The connected ArcGIS account has run out of funds to process requests. 

Resolution

Verify settings are accurate in Administration > System Setup > System Settings. After clicking Save and noting that the verification process remains at 0, the following error should generate in Administration > System Setup > System Log:

System.Net.WebException: The remote server returned an error: (403) Forbidden.     at System.Net.HttpWebRequest.GetResponse()     at Tyler.Standard.ParksRecreation.Business.ActivityEngines.ResidentVerifyManager.VerifyResidentByArcGisOnlineService(String completedUri, Boolean isClassResidentVerify, Int32 tenantId) in C:\BuildAgent\work\31d79ef7d4b32b41\Tyler.Standard.ParksRecreation.Business\ActivityEngines\ResidentVerifyManager.cs:line 135


Contact ESRI Support to add funds to an ArcGIS developer account. 

Additional Information