Cashiering Error Encountered While Performing Search in External System - 404 Not Found

Description of Issue

When searching for items in Cashiering, such as an EnerGov invoice or Munis customer, you get: Error encountered while performing item search in external system xxxx. Additional details or system logs show an exception of 404 Not Found

Error encountered while performing item search in external system EnerGov. Exception (System.Exception): The remote server returned an error: (404) Not Found.

Error encountered while performing customer search in external system Munis. Exception (System.Exception): The request failed with HTTP status 404: Not Found

Context
  • Tyler Cashiering
  • EnerGov
  • Munis
  • External System
  • Integration
Cause

Incorrect URL entry in the External System settings 

Resolution
  1. Log into Cashiering with an administrator account
  2. Navigate to Administration > External Systems
  3. For the applicable External System, click Edit
  4. Update connection URL to the correct value
  5. Click Save

EnerGov

  • Verify the accuracy of the current EnerGovWebApiRootUrl 
    • This is the URL to the EnerGov Service that is used to connect Tyler Cashiering to EnerGov
    • In Tyler Deploy, this is the Integration Web API URL
    • Ex: https://energov.tylertown.org/energov_test/integrationwebapi/api/
  • Verify the MainAppUrl
    • This is the URL to the EnerGov application
    • In Tyler Deploy, this is the EnerGov Shell URL
    • Ex: https://energov.tylertown.org/energov_test/energovshell/
  • Check for misspellings and extra characters such as a trailing space
  • Ensure endpoint is still available to Tyler Cashiering application at its respective host

Enterprise ERP (Munis)

Additional Information