OH AFR: Error select account ID: 100

Description of Issue

When running the OH AFR Cash extract an error is displayed: Error select account ID: 100 (no data)

Context
  • Munis
  • Financials
  • Ohio
  • OH AFR Export
Cause

The OH AFR report throws this error when it cannot find the control accounts to pull expenditure or revenue data. This is caused when the control accounts are not setup for the fund or the object range used is incorrect.

Resolution

When this error is encountered, the OH AFR period records will stop on the account directly preceding the account with the missing control accounts:

  1. Navigate to Financials > General Ledger Menu > Inquiries and Reports > State Specific Reports > Ohio Reports > OH AFR Export Reports > View Records to review the period records
  2. Select Search from the Menu Ribbon
  3. Select the Export Type and define the Year the period records were generated for
  4. Review the period records and find the last account that was generate. Review the fund and object code for this account as it will be used to search for the account master record that is causing the error

Munis provides the option to balance to a fund or secondary level (sub fund). First confirm how Munis has been setup:

  1. Navigate to Financials > General Ledger Menu > Setup/Chart of Accounts > General Ledger Settings
  2. Review the Balancing Level Secondary drop down menu on the  General tab
    1. If the value has not been set then Munis is set to balance on the fund level
    2. If the value has been set, then Munis has been set up to balance to a secondary level

If Munis has NOT been set up to balance to a secondary level:

  1. Navigate to Financials > General Ledger > Setup/Chart of Accounts > Account Master
  2. Select Search from the Menu Ribbon
  3. Enter the Fund from the last period record that the OH AFR Export and click Accept
  4. Review each of the Account Master Records to confirm that each have a set of control accounts:
    1. Select Control Accounts from the Menu Ribbon
    2. Review the browse screen for a list of control accounts. If no accounts exist in the browse, they will need to be added - Contact GL Support

If Munis HAS been set up to balance to a secondary level:

  1. Navigate to Financials > General Ledger > Setup/Chart of Accounts > Account Master
  2. Select Search from the Menu Ribbon
  3. Enter the Fund from the last period record that the OH AFR Export and click Accept
  4. Review each of the Account Master Records to confirm that each have a set of control accounts:
    1. Select Control Accounts from the Menu Ribbon
    2. Review the browse screen for a list of control accounts. If no accounts exist in the browse, they will need to be added
    3. Because Munis is setup to balance to secondary level, an Account Master Record must exist for each control account with the Fund AND secondary balancing code (Function, Object, Program etc.). Contact GL Support

Once the control accounts have been added navigate back to the OH AFR Export and regenerate the records. You should now see all of the expect OH AFR records generate without error.

Additional Information