Can't access Mass Update / Mass Delete in TX PEIMS records view

Description of Issue

While reviewing the TX PEIMS finance records by Munis GL account the Mass Update and Mass Delete options throw an error message stating the user does not have access.

Context
  • Financials
  • Texas
  • TX PEIMS Finance Records
Cause

The Role ID assigned to the user does not have the General Maintenance on Accounts check box checked on the Permissions tab.

Resolution

In order to update the Role ID with the correct permissions:

  1. Navigate to System Administration > Security > Roles
  2. Click Search on the Menu Ribbon and search for the Role ID to be updated
  3. Click the General Ledger option under the Financials header on the Module View tab
  4. Click Update on the Menu Ribbon and check the General Maintenance on Accounts check box on the Permissions tab
  5. Click Accept to save changes

Once the Role ID has been update the user should now be able to access the Mass Update and Mass Delete option in the TX PEIMS Finance Records > Review program. 

NOTE:

  1. This will give the user the ability to maintain GL account records in Account Master. Please be sure to confirm that the user's menu security settings do not provide unwarranted access to the Account Master program.
  2. This permission requirement will be removed when the API changes are made. 
Additional Information