No Tyler Menu in Hub or Dashboard - Services found but not functioning



Description of Issue
  • No user menus in Tyler Hub Prod

  • GAS connection test in MunisHosting returns: Services found but not functioning. Clicking View Details shows System.ServiceModel.FaultException: MUERROR: WS User Authentication Failed.



Context
  • Tyler Menu

  • Hub or Dashboard

  • Munis



Cause

wsuser account isn't passing credentials correctly



Resolution
  1. In Munis Hosting, click the ellipses next to GAS Connection

  2. For GAS user field, enter wsuser

  3. For GAS Password field, enter in what is on file for the wsuser password

  4. Click Test Connection

    1. If it says GAS connection successful, click Save

    2. If it says Services found but not functioning, proceed to next step

  5. Open Munis using the GDC (desktop client) on the App server

  6. Go to System Administration > Security > Passwords

  7. Click the search icon in the ribbon 

  8. Look up the wsuser User ID

  9. If the account is set to Force Password Change (messenger only) click the update/pencil icon, set the status to Active, then click the checkmark/accept

  10. Click Change Password

  11. Enter the correct/desired password

  12. Click OK

  13. Restart GAS for the environment

  14. Test GAS connection and Tyler Menu



Additional Information