Munis Scheduler Monitor service spiking CPU

Description of Issue

The Munis Scheduler Monitor service is generating duplicate processes. This eventually leads to so many excessive processes, the CPU will spike to 99-100% on the Enterprise ERP Application server.

In Task Manager, you may see gdc.exe processes becoming Suspended

You will see the following error within Event Viewer:

Faulting application name: gdc.exe, version: 3.20.11.0, time stamp: 0x5e2ff834
Faulting module name: vm3dgl64.dll, version: 3.6.0.0, time stamp: 0x66a16726
Exception code: 0xc0000005
Fault offset: 0x0000000000e3696d
Faulting process id: 0x64e0
Faulting application start time: 0x01db23e0c0142215
Faulting application path: d:\munprod\gdc\bin\gdc.exe
Faulting module path: C:\Windows\SYSTEM32\vm3dgl64.dll
Report Id: e9bda5fb-5d0b-4538-9aba-ec8a0aee6103
Faulting package full name:
Faulting package-relative application ID: 

Context
  • Enterprise ERP

  • Performance

  • Munis Scheduler

  • Scheduler

  • gdc.exe

Cause

This issue is caused by a corrupted VMWare DLL located at: C:\Windows\SYSTEM32\vm3dgl64.dll following a VMWare Tools update to version 12.5.0 on the Enterprise ERP application server. A number of other software services (not Tyler related) were also impacted by the same issue.

Resolution

Temporary workaround to reduce impact on the CPU:

  1. On the Enterprise ERP Application server, open Services (services.msc)

  2. Locate Munis Scheduler Monitor [env], Port=xxxx

  3. Right click the service and click Stop 

Resolution: Revert any recent VMWare Tools updates on the Enterprise ERP application server 

  1. Uninstall VMWare Tools 12.5.0

  2. Install VMWare Tools 12.4.0

Additional Information