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Exception Error When Updating Employee Pay Period

Exception Error When Updating Employee Pay Period



Description of Issue

The following error occurs when attempting to update an employee's pay period.

Error while trying to save: java.lang.IllegalStateException: Tried to insert two EmployeePayPeriod objects with infinite validity (IDs xx and null, startDates xxx-xx-xx 00:00:00.0 and xxxx-xx-xx 00:00:00.0).



Context
  • Time & Attendance

  • ExecuTime

  • Pay Period

  • Exception Error



Cause

The original pay period assigned to the employee used specific dates that had not been filled in beyond 2020. The specific dates needed to be filled in for 2021, 2022 and at least the start of 2023. This was in a Test environment.



Resolution

Use the following steps to fill in the remainder of the dates.

  1. Navigate to System Admin

  2. Select Master File Management

  3. Select Pay Periods

  4. Click the pencil icon for the pay period in question

  5. Select the year drop-down and select the appropriate year

  6. Review the pay period start / end date and input the start date and end date of your pay period

  7. Select the + icon to add the date and continue adding the dates into the future.

  8. Click Save once completed



Additional Information












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