Time and Attendance Update Failing on Acquire Packages Step

Description of Issue

While running a Time & Attendance update in Tyler Deploy, it is failing on Acquire packages:

The step failed: Activities failed with errors 'A request was sent to a polling endpoint, but the polling endpoint did not collect the request within the allowed time (00:05:00), so the request timed out. Server exception: System.TimeoutException: A request was sent to a polling endpoint, but the polling endpoint did not collect the request within the allowed time (00:05:00), so the request timed out.', 'A request was sent to a polling endpoint, but the polling endpoint did not collect the request within the allowed time (00:05:00), so the request timed out. Server exception: System.TimeoutException: A request was sent to a polling endpoint, but the polling endpoint did not collect the request within the allowed time (00:05:00), so the request timed out.'

Context
  • Tyler Deploy
  • Time & Attendance
  • ExecuTime
  • Acquire Packages
Cause

This error can be caused by multiple factors but ultimately it is a result of a connectivity issue between the Tyler Deploy servers and the client server(s).

The most common causes are:

  • Antivirus is actively scanning or blocking the deployment package as it runs
  • Firewall is severing the connection
  • Slow internet speeds on client network
Resolution
  1. Ensure your Target Servers are showing as healthy in Tyler Deploy: How to Check the Health of a Target Server in Tyler Deploy
    1. If a server is reporting as Unavailable, restart the Octopus Tentacle service in Services.msc on the Target Server. Run the Check Health option after for the server in Tyler Deploy to ensure it come's back as healthy
  2. Ensure that the necessary Antivirus exclusions are in place from active scanning on the server(s):
    1. Antivirus Exclusion List for Time and Attendance and Tyler Workflow
    2. Please also ensure that executables and PowerShell scripts are allowed to run from these directories
  3. Verify the following TCP Firewall Ports are open on your server(s): 
    1. tylerdeployer.tylerdeploy.com:10943
      tylerdeployer2.tylerdeploy.com:10944
      tylerdeployer3.tylerdeploy.com:10945
      tylerdeployer4.tylerdeploy.com:10946
      tylerdeployer5.tylerdeploy.com:10947
      tylerdeployer6.tylerdeploy.com:10948
      tylerdeployer7.tylerdeploy.com:10949
      tylerdeployer8.tylerdeploy.com:10950
  4. Ensure there are no network bandwidth issues or disruptions to your internet service provider

Please contact Tyler System Management support if further assistance is required