General Billing Electronic Fund Transfer Locked Fields

Description of Issue

How to change Site Information fields in Electronic Funds Transfer

Some fields can't be changed in Electronic Funds Transfer

Fields greyed out in Electronic Funds Transfer

How to change the Account Number

How to change Name, Bank and Transit Number in Electronic Funds Transfer

Context
  • Munis
  • General Billing
  • Electronic Funds Transfer
  • Bank Codes
Cause

In this scenario the Electronic Funds Transfer program will not let users update specific fields during a Define. The specific fields are Name, Bank, Transit Number and Account Number. 

Resolution

These fields are pulled from the General Billing Settings program and filed under the EFT section. This is where a user can directly change the Account Number. Furthermore, here the Name and Bank can also be changed however the Bank can be changed or selected via an ellipses chooser in the field. These selections are derived from the Bank Codes program specifically from System Administration>Miscellaneous Administration>Bank Codes. 

Once the above information is updated accordingly, user(s) will need to re-open the Electronic Fund Transfer program and click Define for the information to be updated in those fields. This information will now be already populated moving forward. 

Additional Information