Program missing from Munis main menu despite being granted on active role

Description of Issue

Program missing from Munis main menu despite being granted on active role

Munis Menu item missing

Context
  • Munis Main Menu
  • Menu Settings
  • Roles
Cause

Allow Access box is not checked for the menu defined on a role assigned to the user

Resolution

Each role has a menu defined on it that is used for base menu access, if this menu does not include the Allow Access check box for a specific program, that item will not display on the menu, despite granting access to the program on an assigned role.

To locate the menu being used on a role

Munis > System Administration > Security > Roles

  1. Open Roles
  2. Search  for the role you're reviewing
  3. At the top of the screen, note the Menu Access value

Update the Base Menu

Munis > System Administration > General Administration > Menu Settings

  1. Search for the menu located from the steps above
    1. This is often the Munis Main Menu and does not require searching
  2. User Forward and Back to navigate through, Click Edit to modify access
    1. In order to grant access to a menu item, it must have a direct menu path through to the end program
  3. Click Accept to save changes
  4. Once changes are saved, select Base Menu Settings
  5. Click Menu Update > Yes > Accept
    1. This process prompts Munis to rebuild the menu the next time users log in to ensure that all updates are visible on their menu
Additional Information