Blank Hub page after successful ADFS login

Description of Issue

Hub loads blank page after logging in.

Context
  • Hub
  • ADFS
  • Azure
  • Tyler Identity Local (TID-L)
Cause

Multiple causes:

  • Incorrect userNameClaimType specified in Hub configuration
  • AAD values defined incorrectly in AuthTokenServer configuration
  • User is not properly synced in Azure (Client side)
Resolution

Contact Tyler Systems Management and reference this article.

Additional Information

Hub error log: An exception occurred while attempting to retrieve a refresh token. See the inner exception for more details. ---> System.InvalidOperationException: invalid_grant

Please review the Master Article - Tyler Hub for all related topics.