Access Denied message when accessing Exceptions through Deduction and Benefit Master

Description of Issue

A user has access to Deduction and Benefit Master, but when clicking on Exceptions in the tool bar gets the following message:

Access to this is denied due to security set by your system administrator.

Context
  • Enterprise ERP Payroll

  • Deduction and Benefit Master

  • Payroll Exceptions

  • RBAC

  • Roles

  • User Attributes

Cause

Although accessible through Deduction and Benefit Master, this is also a separate item in Tyler Menu, and user does not have menu access under their Role.

Resolution
  1. Navigate to System Administration>Security>User Attributes.

  2. Search for User ID and click Accept.

  3. Locate and click on the Role through which the user has access to Payroll and that should be updated.

    1. Updating the role for this user will update it for any other user assigned to that role.

  4. Click Edit Role.

  5. Click on the Menu Security tab.

  6. Click on each of the following steps: Human Capital Management > Payroll > Payroll Administration and click Forward after each selection.

  7. Click Edit.

  8. Locate line for Payroll Exceptions and check box under Role Access.

  9. Click Accept.

  10. Once done, have the user log out, log back in, and refresh Tyler Menu on the Hub.

    1. Click the vertical ellipsis next to Tyler Menu and then Refresh.

Additional Information