No Payment Methods Appear for Invoice Payment in Citizen Portal
Description of Issue
When a citizen signs into the Portal to pay on an invoice, they can view their unpaid invoices, but when they Click Here to Make a Payment, no Payment Methods appear in the drop down.Â
Context
TPAR
Parks & Rec
Tyler Parks and Recreation
Citizen Portal
Cause
This page is particularly sensitive to cached data.Â
Resolution
Inform the citizen to try the following steps:
With the internet browser open, type CTRL+SHIFT+DEL
Select Cache and click Clear Now.Â
Reload the Citizen Portal page and try the payment again.Â
Additional Information
Wording of the Clear Recent History menu may differ slightly depending on the citizen's browser.Â