No Payment Methods Appear for Invoice Payment in Citizen Portal

Description of Issue

When a citizen signs into the Portal to pay on an invoice, they can view their unpaid invoices, but when they Click Here to Make a Payment, no Payment Methods appear in the drop down. 

Context
  • TPAR

  • Parks & Rec

  • Tyler Parks and Recreation

  • Citizen Portal

Cause

This page is particularly sensitive to cached data. 

Resolution

Inform the citizen to try the following steps:

  1. With the internet browser open, type CTRL+SHIFT+DEL

  2. Select Cache and click Clear Now. 

  3. Reload the Citizen Portal page and try the payment again. 

Additional Information

Wording of the Clear Recent History menu may differ slightly depending on the citizen's browser.Â