Not Receiving Scheduler Notifications

Description of Issue

Scheduler notifications are not working

Context
  • Scheduler Queue

  • Assess Late Fees

  • Transfer of Overpayments

Cause

The Munis Scheduler Notifications event type relevant to the resulting scheduler job result has not been selected

Resolution

When scheduling a process, and Execute this report is set to At a scheduled time in the program define, the Munis Scheduler window will open. Clicking the Notify button will open the Munis Scheduler Notifications window. Under the Event heading, there are three dropdown menus. From here, the events which prompt a notification can be determined as desired. The six event types are:

  • When job starts

  • When job completes

  • When job completes, include document link(s)

  • If job completes w/ error

  • If job expires

  • If job is deleted

Bear in mind that only three event types of six can be chosen for any given scheduled job, therefore, in troubleshooting why scheduler notifications are not generating, it's important to consider the circumstances. For instance, in a scenario where the define entered results in No records selected, but If job completes w/ error was not selected as an event type, there will be no notification generated. Similarly, in a scenario where an incomplete process, such as Assess Late Fees or Transfer of Overpayments, applies to a bill, the system will prevent additional like processes from being run on that bill until the previous process has been completed. 

It is advised to begin troubleshooting by verifying there are no incomplete processes in the scheduled program(s), which concern the same bill(s) in the current define. Then, test scheduling two identical jobs, using all six different event types between the two, so that effectively, no notification event types are filtered out.

Additional Information