Cash account not defined message when entering Miscellaneous Receipt

Description of Issue

When entering a Miscellaneous Receipt, the message Cash account not defined. A valid account is required. is received. 

Context
  • Accounts Receivable
  • General Billing
  • Miscellaneous Receipts
  • Payment Entry (arbilinq)
Cause

The Cash account entered does not exist.

Resolution
  1. Double check that the Cash account as entered is correct. 
  2. To verify that the account exists, the user or a member of the finance team can navigate to the Account Master program: Financials > General Ledger Menu > Set Up/Chart of Accounts > Account Master
  3. Click Search. 
  4. Enter the Org code, Object code, Project code, Fund, Function, Department, Program, Division, DOE Program, DOE Function, Category, Object, and Project as it is entered in the Cash account field in Payment Entry. 
  5. Click Accept. 
  6. If no records return, then that account does not exist. 

Development is researching an issue where GL Accounts of max length are truncated when the user is entering a Miscellaneous Receipt and their User Attributes are set to L - Full Account - Line. 

As a workaround, users can either have their User Attributes temporarily updated to O - Org, (instructions to do this can be found here: How to change account entry during Miscellaneous Receipts entry from Org to Full Account) or can click Accept immediately after entering the Charge Code instead of TABBING. 

Additional Information

Additional resources for working in Payment Entry can be found here: Master Article - Payment Entry