AWS SSRS unable to connect to Builder_xxxxx datasource from Report Builder

Description of Issue

When trying to refresh a query or create a dataset, report builder shows a network error when using Builder_xxxx datasource

Context
  • EERP all versions

  • AWS Lighthouse

  • SaaS hosted Clients

  • SSRS Reports

  • Tyler Reporting Services

Cause

There are numerous reasons why the report builder might display this error. However, more often than not, it's because the F5 VPN isn't being utilized.

Resolution

Exact error message in Report Builder:

A network-related or instance-specific error occurred while establishing a connection to SQL Server.

The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections.


Resolution:

This error message indicates Report Builder is unable to connect to database server mentioned the shared datasource, which is likely caused because F5 VPN is not being utilized.

The following article provides instructions on connecting to F5 VPN: Connecting to F5 VPN


If the error persists, please reach out to EERP Reporting Services Support team as the database server likely need to be made available for external access.

Additional Information